[Public WebGL] Typed Array slice() renamed to subarray() (was: subset())

Vladimir Vukicevic [email protected]
Thu Feb 3 23:45:58 PST 2011

----- Original Message -----
> Hi Vlad,
> On Fri, Feb 4, 2011 at 03:54, Vladimir Vukicevic
> <[email protected]> wrote:
> > Second, at the last minute (after some discussion with wider JS
> > folks), we ended up renaming this to subarray() instead of subset().
> > (...)
> > Third, sorry again for the second quick rename!
> It was so quick we didn't notice it ;-)
> What do you think of the proposed change supported by Mark and myself
> regarding specification of Typed Arrays 'enumerability' ?

Unfortunately I don't think it's one that we can actually specify -- the reason that it's inconsistent currently in the various engines is that they all have various internal enumeration bits that would have to change.  I -think- ES5 specifies this a lot more tightly, though, so eventually all engines should do the same thing.

    - Vlad
You are currently subscribed to [email protected]
To unsubscribe, send an email to [email protected] with
the following command in the body of your email:
unsubscribe public_webgl

More information about the public_webgl mailing list